PHP Manager Fails To Install On IIS Via WebPI

Sharing Options:
Estimated Reading Time: 2 Minutes

 

PHP Manager Fails To Install On IIS Via WebPIPHP Manager Fails To Install On IIS Via WebPI

When attempting to install PHP on IIS 8 (2012 Server) or IIS 10 (2016 Server) you may get the following error during WebPI installation:

We’re sorry, the following products have failed to install.

PHP Manager For IIS
The product did not install successfully: Fatal error during installation.

Note: You should have the IIS role installed, including ASP, ASP.NET, HTTP Redirection, CGI (Under application development) and anything else you may need.  You should also have the .NET Framework 3.5 Installed  [More Info Here].  The WebPI will automatically add the necessary Visual C++ Redistributable that is needed for the version of PHP you are installing.

This PHP Manager error is typically caused by an incorrect registry setting, that can be easily modified.

  • Open regedit, and track to the following key:
    • HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W3SVC/Parameters/MajorVersion
    • Change the decimal value from (10) to (8)
  • The installer will now complete successfully, once it completes, you can change this setting back to decimal 10.

 

Undo The WebPI Installation (optional):

  • If you need to uninstall the WebPI changes and ‘start over’ – you can follow the directions [here] to modify the applicationhost.config file.
  • After you’ve fixed the applicationhost.config file (usually in c:\windows\system32\inetsrv\config), you should also remove the PHP folders in the root directory of your hard drive, but also check the Program Files (x86) and Program Files folders.
  • All PHP folders should be removed if you are trying to back out the WebPI installation.
  • At this point, you can close WebPI and re-launch, attempting reinstall.  Remember to set the MajorVersion key back to the original value once everything is installed.

 

Update: April 2020 – after performing the above steps on later versions of Windows Server 2016 and all versions of Windows Server 2019, you may receive an error still about the PHP Manager.  To correct this, you need to install a newer (modified) version of the stand-alone PHP Manager installer available here: [GitHub Respository].  Alternately, from the [iis.net website].  Look for the latest version for IIS 10.  After installing this update, you will again see the PHP Manager within the IIS Management Snap In.

 

Tags: #php #iis #windows #server #iis10 #techsupport

Sharing Options:

Recommended

Be the first to comment